All services have been restored. We are actively monitoring the situation to ensure stability and prevent any recurrence of the issue.
Posted Sep 05, 2025 - 11:27 PDT
Update
Some services have been partially restored, while others continue to experience disruptions. Our team is actively investigating the root cause and working to fully resolve the issue. We will share additional updates as soon as they become available.
Posted Sep 05, 2025 - 10:48 PDT
Investigating
We are currently experiencing a service outage impacting all our solutions (Intake, Conflicts, Flow, Time, Terms, Walls, Intapp Integration Service and DealCloud) in the US region. During this time, users will be unable to access the application. Our team is actively investigating the issue, and we will share updates as soon as more information becomes available.
Posted Sep 05, 2025 - 10:16 PDT
This incident affected: US (DealCloud PS US1, DealCloud Data Connector US1, Risk/Flow US1, Walls US1, Flow US1, Employee Compliance US1, Time US1, Billstream US1, Pricing US, Intapp Integration Service (IIS) US1, Experience US).