A fix has been implemented and we are monitoring the results. Further updates will be posted shortly.
Posted Jun 02, 2025 - 11:23 PDT
Update
We are continuing to investigate this issue.
Posted Jun 02, 2025 - 11:06 PDT
Investigating
We are currently experiencing a service degradation affecting some tenants of our Time solution in the US region. Firms who are experiencing this degradation will receive a client error stating "An error was encountered while synchronizing working profiles" Our team is actively investigating the cause, and we will provide updates as more information becomes available.