We are continuing to work on a fix for this issue.
Posted Aug 06, 2026 - 18:10 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 06, 2026 - 17:07 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 06, 2026 - 15:58 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 06, 2026 - 14:44 PDT
Identified
The issue with US Time has been identified and a fix is being put in place. Clients may experience degraded performance while the solution is being applied.
Posted Aug 06, 2026 - 13:40 PDT
Investigating
We are currently experiencing a outage affecting our Time solution in the US region. Our team is actively investigating the cause, and we will provide updates as more information becomes available.