Intapp Billstream Degradation of Service [USA]

Incident Report for Intapp, Inc.

Resolved

The issue has been resolved. All services are operating as normal.
Posted Aug 17, 2026 - 10:23 PDT

Monitoring

The fix has been implemented, and all systems are now operational. We will continue to monitor the situation closely.
Posted Aug 17, 2026 - 08:35 PDT

Update

Our engineering team continues to work on deploying the fix. We will provide another update shortly.
Posted Aug 17, 2026 - 07:37 PDT

Identified

We are currently experiencing a service degradation affecting our Billstream solution in the USA region. Users may experience issues logging in to the application.

Our team has identified the issue and is actively working to implement a fix. We will provide further updates as more information becomes available.
Posted Aug 17, 2026 - 06:36 PDT
This incident affected: US (Billstream US1).