Intapp DealCloud PS Production Degradation of Service EU and US Region

Incident Report for Intapp, Inc.

Resolved

We have resolved the incident.
Posted Feb 20, 2026 - 09:07 PST

Monitoring

We have resolved the incident and are now monitoring the product.
Posted Feb 20, 2026 - 08:04 PST

Investigating

We are currently investigating and users may experience slowness while using the application.
Posted Feb 20, 2026 - 07:11 PST
This incident affected: EU (DealCloud PS EU1) and US (DealCloud PS US1).