We has resolved the incident but we are watching to make sure the resolution is complete
Posted Mar 06, 2025 - 15:23 PST
Investigating
We are currently experiencing a service degradation affecting our DealCloud solution in the US region. For clients experiencing the degradation of service, the application might take up to a minute to respond to requests. Our team is actively investigating the cause, and we will provide updates as more information becomes available.
Posted Mar 06, 2025 - 14:21 PST
This incident affected: US (DealCloud US1, DealCloud US3, DealCloud US4, DealCloud US5).