Intapp DealCloud Degradation of Service USA

Incident Report for Intapp, Inc.

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 14:22 PDT

Update

We are actively investigating the root cause of the latency and are diligently working to restore services to optimal performance.
Posted Mar 12, 2025 - 13:10 PDT

Investigating

We are currently experiencing a service degradation affecting our DealCloud solution in the USA region. Users may experience some latency while using the application. Our team is actively investigating the cause, and we will provide updates as more information becomes available. Please be advised that this only impacting clients on DealCloud US 3.
Posted Mar 12, 2025 - 12:00 PDT
This incident affected: US (DealCloud US3).