The issue has been resolved. All services are operating as normal.
Posted May 06, 2026 - 08:06 PDT
Identified
We have identified the issue as being related to pivot table usage. While we work on a fix, the following changes can improve performance in the meantime:
Where possible, replace pivot tables with a Table widget, both of which are lighter. If a pivot is required, reduce the number of Values configured, as each value adds calculation overhead. Avoid using Columns in pivots - these are resource-intensive. Where possible, convert Columns to Rows instead.
Posted May 06, 2026 - 05:03 PDT
Investigating
We are currently experiencing a service degradation affecting our Reporting solution in the EU region. Our team is actively investigating the cause, and we will provide updates as more information becomes available.
Posted May 06, 2026 - 03:46 PDT
This incident affected: EU (Risk/Flow EU1, Time EU1).