A fix has been implemented in production, and we are monitoring the results. Sandbox is still impacted for some users.
Posted Mar 03, 2025 - 10:43 PST
Monitoring
A fix has been implemented, and we are actively monitoring the results. Further updates will be provided shortly.
Posted Mar 03, 2025 - 07:41 PST
Update
The issue appears to be isolated to users accessing our solution from the Atlanta region, where they are unable to access or load the DealCloud site. Our team is actively investigating the root cause and working toward a resolution. We appreciate your patience and will provide updates as soon as more information becomes available.
Posted Mar 03, 2025 - 06:41 PST
Investigating
We are currently experiencing a service degradation impacting our DealCloud solution in the US and EU regions. Our team is actively investigating the issue, and we will share updates as soon as we have more information.
Posted Mar 03, 2025 - 06:03 PST
This incident affected: EU (DealCloud EU1, DealCloud PS EU1) and US (DealCloud US1, DealCloud US3, DealCloud US4, DealCloud US5, DealCloud PS US1).