We have encountered an issue with the maintenance and will rollback the changes. We will schedule another maintenance window in the future to complete the changes.
Posted Mar 27, 2025 - 15:07 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 27, 2025 - 12:01 PDT
Scheduled
SERVICE IMPACT There will be a downtime during the maintenance window that can occur any time after the maintenance start is announced via the status site. Do not perform any large data imports or changes during the four-hour maintenance window. Please communicate this information to all users.
RELEASE CONTENT As part of our ongoing commitment to improve our services, we will be updating inbound and outbound IP addresses used by DealCloud. Please be advised that this change will affect all connections to and from DealCloud across the Preview and Production environments. This maintenance window is specific to the UAE Preview. Please refer to this community post for more details on timing and be sure to subscribe to the status page for real-time updates on this scheduled maintenance window.