The issue has been resolved. All services are operating as normal.
Posted Apr 25, 2026 - 09:15 PDT
Update
We are continuing to monitor while Azure services recover. No additional updates expected this evening.
Posted Apr 24, 2026 - 17:53 PDT
Update
Azure services are continuing to recover, and we are actively monitoring the situation.
Posted Apr 24, 2026 - 12:42 PDT
Monitoring
A service outage in the Azure East region adversely affected data processing for Snowflake accounts, resulting in delays. Azure services are currently recovering, and we are actively monitoring the situation.
Posted Apr 24, 2026 - 11:20 PDT
This incident affected: US (DealCloud Data Connector US1).