The issue has been resolved. All services are operating as normal.
Posted Jul 02, 2025 - 14:04 PDT
Update
We are still investigating the service degradation affecting DealCloud in the US region. Our team is actively working to resolve the issue. Thank you for your patience.
Posted Jul 02, 2025 - 13:48 PDT
Investigating
We are currently experiencing a service degradation impacting the DealCloud solution in the US region. Users may encounter slow page load times. Our team is actively investigating the issue, and we will share updates as soon as more information becomes available. We appreciate your patience and understanding.