Risk/Flow Release 2505 – US/CA/AP Sandbox

Scheduled for Apr 24, 23:00 PDT  -  Apr 25, 03:00 PDT

Update

Updated release to 2505.
Posted Apr 18, 2025 - 10:12 PDT

Scheduled

SERVICE IMPACT
In the 2505 feature release, we are making a change that will require you to reauthorize your Intapp Cloud data sources in Integrate for Risk/Flow. Once you are notified the maintenance has been completed, you need to reauthorize your Intapp Cloud data sources in Integrate for Risk/Flow to ensure data sources are available. Please note that Technology Foundation Datasources will not need to be reauthorized. Please monitor the upcoming maintenance announcements for your region. We apologize for any inconvenience with respect to this change.

For more detailed information on the actions required, please consult the following note on the Support portal: Action Required following 2505 Release for Risk/Flow Cloud Clients Using Integrate

There will be no downtime associated with this release. Some users may be logged out during the release, but they will be able to log back in immediately. We recommend that you do not perform any large data imports or changes until the maintenance is completed. The service disconnection can occur any time after the maintenance start is announced via the status site.

We encourage you to review the new features and defect fixes.

RELEASE CONTENT
The 2505 release includes features and enhancements to Intake, Flow, Conflicts, and Terms. The Intake and Flow releases include updates to data sets, enhancements to the Form Designer, a new Generate File state type in the Workflow Editor, and improved notification configuration for attachments. Intake also introduces the ability to generate a summary for requests meeting certain criteria. Conflicts introduces updates to Assisted Conflicts APIs and user interface, as well as support for integration between Walls and Conflicts for cloud tenants. Terms includes a new Billstream Enforcement Terms integration, along with enhancements to Terms Tasks, the API, CDS, AI, and overall user experience. Across all products, the release includes the ability to opt-in to a new user interface, API enhancements, other user experience improvements, and bug fixes.

For more information on the new features, enhancements, and defect fixes, please review the release notes on the Support Portal at the links below.

Intapp Intake Release Notes
Intapp Conflicts Release Notes
Intapp Terms Release Notes
Intapp Flow Release Notes

ADDITIONAL INFORMATION
- If you have any questions, please contact support@intapp.com.
Posted Apr 18, 2025 - 10:05 PDT
This scheduled maintenance affects: CA: Non-Production (Risk/Flow CA1 - Sandbox, Flow CA1 - Sandbox), AP: Non-Production (Risk/Flow AP1 - Sandbox), and US: Non-Production (Risk/Flow US1 - Sandbox, Flow US1 - Sandbox).