A fix has been implemented. Services are fully recovered and we are currently monitoring the results. Further updates will be shared soon.
Posted Sep 05, 2025 - 08:36 PDT
Update
Recovery of services is underway, and systems are beginning to come back online. We continue to investigate and work toward identifying the root cause. Further updates will be shared as more information becomes available.
Posted Sep 05, 2025 - 08:19 PDT
Update
We are continuing to investigate the root cause of the issue. We apologize for the inconvenience and appreciate your patience as we work toward a resolution.
Posted Sep 05, 2025 - 07:35 PDT
Update
We are continuing to investigate the root cause of the issue. We apologize for the inconvenience and appreciate your patience as we work toward a resolution.
Posted Sep 05, 2025 - 07:05 PDT
Update
We are continuing to investigate this issue.
Posted Sep 05, 2025 - 06:32 PDT
Investigating
We are currently experiencing a service outage impacting all our solutions (Intake, Conflicts, Flow, Time, Terms, Walls, Intapp Integration Service and DealCloud) in the US region. During this time, users will be unable to access the application. Our team is actively investigating the issue, and we will share updates as soon as more information becomes available.
Posted Sep 05, 2025 - 06:30 PDT
This incident affected: US (DealCloud PS US1, DealCloud Data Connector US1, Risk/Flow US1, Walls US1, Flow US1, Employee Compliance US1, Time US1, Billstream US1, Pricing US, Intapp Integration Service (IIS) US1, Experience US).