Azure services are continuing to recover, and we are actively monitoring the situation. Clarification: Earlier we stated that "Azure has confirmed resolution of the incident." however, Azure have confirmed the root cause is actively being corrected. Some services may still see minor degraded performance as they recover.
Posted Apr 24, 2026 - 12:50 PDT
Monitoring
Azure have confirmed resolution of the incident. We will continue monitoring the system for additional impact.
Posted Apr 24, 2026 - 11:24 PDT
Update
The issue is ongoing, and we are awaiting resolution from the provider. We'll provide updates as they are available.
Posted Apr 24, 2026 - 11:01 PDT
Update
The issue is ongoing, and we are awaiting resolution from the provider. We'll provide updates as they are available.
Posted Apr 24, 2026 - 10:00 PDT
Update
The issue is ongoing, and we are awaiting resolution from the provider. We'll provide updates as they are available.
Posted Apr 24, 2026 - 09:07 PDT
Identified
We have identified the issue as an Azure‑related matter and are awaiting action from the service provider. Further updates will be posted as they are available.
Posted Apr 24, 2026 - 08:03 PDT
Investigating
We are currently experiencing a degradation of service. Our teams are currently investigating.