Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 29, 2026 - 23:01 PST
Update
SERVICE IMPACT Please communicate to your users that there will be a downtime at some point during the 4-hour maintenance window. The service will be unavailable for up to 240 minutes and this can occur any time after the maintenance start is announced via the status site. Do not perform any large data imports or changes until the maintenance is completed.
We encourage you to review the new features and defect fixes.
RELEASE CONTENT The 2602 release includes features and enhancements to Intake, Flow, Conflicts, and Terms. The Intake release includes enhancements to Quick Start. The Conflicts release includes API enhancements, and updates to the Intapp Watch List service. Intake and Conflicts releases include a new configuration that allows admins to hide the Conflicts clearance summary from the Activities log. The Terms release includes improvements for the Terms API. All releases include enhancements for user experience and CDS.
For more detailed information on the new features and a complete list of defect fixes, please review the release notes on the Documentation Portal: Intapp Release Notes
ADDITIONAL INFORMATION - If you have any questions, please contact support@intapp.com.
Posted Jan 29, 2026 - 13:46 PST
Scheduled
SERVICE IMPACT Please communicate to your users that there will be a downtime at some point during the 4-hour maintenance window. The service will be unavailable for up to 240 minutes and this can occur any time after the maintenance start is announced via the status site. Do not perform any large data imports or changes until the maintenance is completed.
We encourage you to review the new features and defect fixes.
RELEASE CONTENT The 2602 release includes features and enhancements to Intake, Flow, Conflicts, and Terms. The Intake release includes enhancements to Quick Start. The Conflicts release includes API enhancements, and updates to the Intapp Watch List service. Intake and Conflicts releases include a new configuration that allows admins to hide the Conflicts clearance summary from the Activities log. The Terms release includes improvements for the Terms API. All releases include enhancements for user experience and CDS.
For more detailed information on the new features and a complete list of defect fixes, please review the release notes on the Documentation Portal: Intapp Release Notes
ADDITIONAL INFORMATION - If you have any questions, please contact support@intapp.com.