Intapp Dealcloud Degradation of Service EU Region

Incident Report for Intapp, Inc.

Resolved

This incident has been resolved.
Posted May 27, 2025 - 11:47 PDT

Update

We are continuing to work on the issue, and we will provide updates as more information becomes available.
Posted May 27, 2025 - 11:17 PDT

Monitoring

A fix has been implemented and we are monitoring the results. Further updates will be posted shortly.
Posted May 27, 2025 - 08:59 PDT

Investigating

We are currently experiencing a service degradation affecting our Dealcloud solution in the EU region. Users may experience delays when performing actions within the application. Our team is actively investigating the cause, and we will provide updates as more information becomes available.
Posted May 27, 2025 - 08:44 PDT
This incident affected: EU (DealCloud EU1).