A fix has been applied and we are monitoring to confirm full recovery. Users should begin to see performance return to normal when accessing DealCloud (EU Production). We will confirm resolution shortly.
Posted Sep 08, 2026 - 04:36 PDT
Identified
We have identified the cause of the performance issue affecting DealCloud (EU Production). Our engineering team is actively working to resolve it. Users may continue to experience slow page loads or delays in the meantime. We will provide further updates as they come available.
Posted Sep 08, 2026 - 04:31 PDT
Investigating
We are currently experiencing a service degradation affecting our DealCloud (Production) solution in the EU region. Our team is actively investigating the cause, and we will provide updates as more information becomes available. Users may experience slow page loads or delays when accessing the application.