Intapp Dealcloud Application latency (EU)

Incident Report for Intapp, Inc.

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 11:52 PDT

Update

We are continuing to investigate this issue.
Posted Jun 17, 2025 - 09:49 PDT

Update

We are continuing to investigate this issue.
Posted Jun 17, 2025 - 08:45 PDT

Investigating

We have identified the issue and are actively working on a resolution. During this time, users may experience latency or slower performance while using the application.

We appreciate your patience and we will provide further updates shortly.
Posted Jun 17, 2025 - 07:37 PDT
This incident affected: EU (DealCloud EU1).