We continue to monitor the situation. Given the length of time to implement for the solution, further updates will be provided within 24 hours.
Posted Jul 25, 2025 - 15:05 PDT
Update
We are continuing to monitor the situation. The resolution is in still in progress.
Posted Jul 25, 2025 - 10:33 PDT
Update
We are continuing to monitor the situation. The resolution is in progress and is expected to be fully completed within approximately 20 hours.
Posted Jul 25, 2025 - 03:52 PDT
Update
We are continuing to monitor the situation and the resolution. No further updates are expected overnight unless there is a status change.
Posted Jul 24, 2025 - 18:23 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2025 - 14:51 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 24, 2025 - 14:29 PDT
Investigating
We are currently experiencing a service degradation impacting email-based replies within our Open solution in the US region. Our engineering team is actively investigating the issue, and we will provide timely updates as additional information becomes available.