Intapp Dealcloud Degradation of Service (USA)

Incident Report for Intapp, Inc.

Resolved

This incident has been resolved.
Posted May 02, 2025 - 10:22 PDT

Monitoring

Performance has been restored to normal, and the team is monitoring for continuing issues.
Posted May 02, 2025 - 09:26 PDT

Investigating

We are currently experiencing a service degradation affecting our Dealcloud solution in the USA region. Users might experience slow performance affecting the application. Our team is actively investigating the cause, and we will provide updates as more information becomes available.
Posted May 02, 2025 - 08:56 PDT
This incident affected: US (DealCloud PS US1).