Intapp is aware of an issue affecting Intapp Time performance and availability for some customers. Our engineering team is actively working to resolve it.
This issue affects a subset of customers. Administrators at impacted organizations are receiving direct email communications with additional detail and updates.
If you have not received a direct email regarding this issue, no action is required on your part. We will update this notice as the situation progresses.
We will provide the next update once the corrective actions have been completed or if any new information becomes available.
Posted Aug 07, 2026 - 18:16 PDT
Update
We are continuing to investigate this issue.
Posted Aug 07, 2026 - 16:29 PDT
Update
We are continuing to investigate this issue.
Posted Aug 07, 2026 - 15:26 PDT
Investigating
We are currently experiencing a partial outage affecting our Time solution in the US region. Our team is actively investigating the cause.