The issue has been resolved. All services are operating as normal.
Posted Sep 26, 2024 - 06:31 PDT
Monitoring
A fix has been implemented and we are monitoring the results. We had identified a technical issue that may have caused delays in validation data synchronization and, in some cases, synchronization failure messages in the desktop application. The fix has been implemented and we are monitoring results. Further updates will be posted shortly.
Posted Sep 26, 2024 - 05:45 PDT
Investigating
We are currently experiencing a degradation of service relating to our Time solution in the CA region. We are currently investigating the cause of the issue and will provide more information as it becomes available.