A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2026 - 12:15 PDT
Update
We are continuing to investigate this issue.
Posted Mar 26, 2026 - 11:21 PDT
Update
We are continuing to investigate this issue and remediation efforts are underway. We'll provide further updates as they become available.
Posted Mar 26, 2026 - 11:20 PDT
Update
We are continuing to investigate this issue and remediation efforts are underway. We'll provide further updates as they become available.
Posted Mar 26, 2026 - 10:25 PDT
Update
We are continuing to investigate this issue. We'll provide further updates as they become available.
Posted Mar 26, 2026 - 09:23 PDT
Update
We are continuing to investigate this issue.
Posted Mar 26, 2026 - 08:24 PDT
Investigating
We are currently experiencing service degradation impacting our DealCloud solution in the EU region. Users may encounter slower-than-normal page load times. Our team is actively investigating the issue and working to restore full performance as quickly as possible. We will share updates as more information becomes available.
Posted Mar 26, 2026 - 07:29 PDT
This incident affected: EU (DealCloud EU1, DealCloud EU2, DealCloud PS EU1).