The issue affecting DealCloud (US) has been resolved.
Posted Sep 04, 2026 - 03:52 PDT
Monitoring
A fix has been applied and we are monitoring to confirm full recovery.
Posted Sep 04, 2026 - 03:04 PDT
Identified
We have identified the cause of an issue currently affecting DealCloud (US). Users may experience slow page loads, request timeouts, or errors when accessing the application. Our engineering team is actively working to resolve this and we will provide a further update shortly.
Posted Sep 04, 2026 - 02:57 PDT
Investigating
We are currently experiencing a service degradation affecting our DealClous PS solution in the US region. Our team is actively investigating the cause, and we will provide updates as more information becomes available.