Intapp Time Degradation of Service US

Incident Report for Intapp, Inc.

Update

We have resolved the incident and we are monitoring the progress.
Posted Jun 08, 2026 - 11:10 PDT

Monitoring

We have resolved the incident. The system will continue to recover, and we are monitoring the progress.
Posted Jun 08, 2026 - 09:49 PDT

Identified

We have identified the issue and are working on a resolution.
Some users may see errors when editing and releasing time in the Time web experience.
Further updates will be posted shortly.
Posted Jun 08, 2026 - 09:08 PDT
This incident affects: US (Time US1).