A fix has been implemented, and all systems are now operating normally.
Posted Aug 16, 2025 - 10:32 PDT
Investigating
We are currently experiencing a service outage affecting our Dealcloud solution in the USA and APAC region. Our team is actively investigating the cause, and we will provide updates as more information becomes available.
Posted Aug 16, 2025 - 09:53 PDT
This incident affected: US (DealCloud US1, DealCloud US3, DealCloud US4, DealCloud US5, DealCloud US6) and AP (DealCloud AP1).