We are currently experiencing a degradation of service
Incident Report for Intapp, Inc.
Resolved
This incident has been resolved.
Posted Sep 23, 2020 - 19:27 PDT
Investigating
We are currently experiencing a degradation of service. Our teams are currently investigating.
Posted Sep 23, 2020 - 19:14 PDT
This incident affected: OnePlace CRM - US.