This incident has been resolved, we can confirm that the Intapp Time Capture service is fully operational.
Posted Sep 10, 2025 - 06:13 PDT
Monitoring
A fix has been implemented and we are monitoring the results
Posted Sep 10, 2025 - 05:18 PDT
Update
We are continuing to implement a fix for this issue. Service impact may persist during this time. We will provide another update as soon as we have more information.
Posted Sep 10, 2025 - 05:08 PDT
Identified
The issue has been identified and our team is implementing a fix. During this period, you may experience delays in captured activity or find the capture API temporarily inaccessible. We will keep you informed with further updates as they become available.
Posted Sep 10, 2025 - 04:11 PDT
Investigating
We are currently experiencing a service degradation affecting our Time Capture solution in the EU region. Our team is actively investigating the cause, and we will provide updates as more information becomes available.